HideHide

GigPress has been acquired by Modern Tribe

Learn More

GigPress

Live performance listings for WordPress.

Minor update for 1.3.2

Posted by Derek on Friday, June 20th, 2008 | 11

I just posted a small update, fixing a couple of bugs that have popped up and also adding three new translations (Basque, Hungarian and Norwegian – thanks to Iker, AndrĂ¡s and Espen.) See the version history on the download page for details.

I wish I had more time to work on GigPress these days, but it’s been a crazy busy period, and it looks to be getting only crazier for me in the coming months. I wish I could make quicker progress on new features and the like, but my client work has to come first naturally.

One idea I’ve been struggling with is how best to deal with pagination, both in the admin and on the display pages. The tour grouping makes it an interesting problem. If you have some bright ideas for how it might best be handled and want to discuss, drop me a line.

Thanks to all the folks who’ve sent kind words (and kind donations) my way thus far – it’s much appreciated!

11 comments

  1. Jonathan
    June 22nd, 2008
    3:56 pm #

    Hello. First, I’d like to thank you for the plugin and the time you have put into it to make it better. I especially like the ability to copy past gigs (which, in my case, eliminates a lot of extra typing). Again, thanks.

    My question: I know associating a post with a gig is capped at 100, but is there a way to keep the choices to the most recent 100 posts? If not, then all new gig additions can never be associated with a new post. I have over 100 posts and I cannot associate a gig with any recent post. I hope this makes sense. Thanks.

    Jonathan

  2. Derek
    June 22nd, 2008
    4:19 pm #

    @Jonathan – that menu should be populated with the most recent 100 posts, in reverse chronological order. Is this not happening with your installation? If not, then in what order are they displayed? (chronological? alphabetically?)

  3. Jonathan
    June 22nd, 2008
    10:23 pm #

    Derek:

    Thank you for your prompt reply. The posts are chronological, from oldest to newest (oldest, scroll down to newest). However, newest stops at post 100. I wonder what it is?

    Jonathan

  4. urbanized
    June 23rd, 2008
    1:58 pm #

    I love your gigpress plugin- it makes life so much easier for me. I have tweaked a few things as far as the content displayed but I still love it!

  5. Sherwin Techico
    June 30th, 2008
    5:33 am #

    Nice plugin. It would be nice to have an automatic way to have a link to the “upcoming-shows#event page” (per se) when a post is related to a particular show. Making it both ways rather than just the Gigpress show linking to a post. TIA, and keep up the great work!

  6. Sherwin Techico
    July 1st, 2008
    4:15 am #

    Btw, any test findings w/ using it w/ FD Feedburner Plugin (http://flagrantdisregard.com/feedburner/)? I saw that it’s currently not playing nice w/ FeedSmith (as noted in the options page). TIA

  7. Derek
    July 1st, 2008
    9:10 am #

    @ Sherwin – I thought about implementing a reverse link from related posts, but it entailed other variables (is the show in the future or past? If in the past, what’s the location of the “past shows” page? etc), so I left it out for now.

    Re: the FD FeedBurner plugin, looks like it has the same problem as FeedSmith – it hijacks every call to any sort of feed, not just posts and comments. ( I just tested it and confirmed.) I’ll email the author and see if he might be able to correct this.

  8. Sherwin Techico
    July 2nd, 2008
    2:55 am #

    RE: FD FB plugin. Cool, I hope John/FD gets to work it out w/ you.

    Meanwhile, I just posted a Show that was 2008-06-30 9pm. It showed up on the Upcoming Shows Gigpress Admin page, as well as the actual WP Page I published w/ the upcoming-show tag.

    However, today 2008-07-01, I don’t see it in Past Shows Gigpress Admin page (i.e. /wp-admin/admin.php?page=gp-past). It states “No shows in the archive yet”. But, I see it in the DB and on the actual WP Page I published w/ the past-show tag. Anything I can do to see if its a bug, etc.?

    TIA

  9. Derek
    July 2nd, 2008
    9:54 am #

    @Sherwin – I’ve spoken to John, and we’re working on it.

    Re: your bug – I think that it may be. I’m sending you an email to see about a potential fix for this issue (it was reported by someone else as well.)

  10. Sherwin
    July 2nd, 2008
    12:29 pm #

    Alright, I’ll update when I get home later tonight. TIA

  11. Sherwin
    July 2nd, 2008
    12:46 pm #

    Cool. I was able to do the quick update. That fixed it. Thanks Derek.

Comments are closed.